TShopping

 找回密碼
 註冊
搜索
查看: 4772|回復: 0

[教學] ethereum 乙太幣挖礦 出現ERROR 更改設定

[複製鏈接]
發表於 2016-12-29 07:13:41 | 顯示全部樓層 |閱讀模式
 
Push to Facebook Push to Plurk  
1.png
2.png

筆者用MSI 380 2G時出現此問題
可用指令,找到顯卡內容明細
  1. ethminer --list-devices
複製代碼
顯示
D:\Ethereum 0.9.41\Release>ethminer --list-devices

Listing OpenCL devices.
FORMAT: [deviceID] deviceName
[0] Tonga
        CL_DEVICE_TYPE: GPU
        CL_DEVICE_GLOBAL_MEM_SIZE: 4294967296
        CL_DEVICE_MAX_MEM_ALLOC_SIZE: 3019898880
        CL_DEVICE_MAX_WORK_GROUP_SIZE: 256

執行
ethminer -G  -F http://coinotron.com:3342/nozero.x:123

出現錯誤訊息
Ethereum Mining – “GPU can’t allocate the DAG in a single chunk”


該怎麼解呢?

增加
  1. setx GPU_FORCE_64BIT_PTR 0
  2. setx GPU_MAX_HEAP_SIZE 100
  3. setx GPU_USE_SYNC_OBJECTS 1
  4. setx GPU_MAX_ALLOC_PERCENT 100
  5. setx GPU_SINGLE_ALLOC_PERCENT 100
複製代碼

也可在執行檔加參數,試試看
  1. --cl-extragpu-mem 0
複製代碼
AMD SDK裝到最新版 http://developer.amd.com/tools-a ... processing-app-sdk/

AMD驅動最適合版本 15.12

說明
A very brief overview of the variables and their available values are as follows:

GPU_FORCE_64BIT_PTR   [0 |  1] – When set to 0 this setting allows access to 32-bit address space of memory ~3.8 GB. When set to 1 it allows access to 64-bit address space. While it may sound like a good idea to set it to 1, it may actually hurt performance since then pointer access would require twice the number of clock cycles to complete than it would if left in 32bit mode. Note: For gaming leave this set to 1, especially if you want to use all of your memory in 4GB+ cards.
GPU_MAX_HEAP_SIZE   [0 – 100] – By default the memory made available to OpenCL is limited to just 50% of total GPU memory. With this setting it is possible to increase the amount of memory available up to 100%
GPU_USE_SYNC_OBJECTS   [0 | 1] – Syncs the System CPU with the GPU actions to improve performance, 0 is thought to lock usage to a single CPU core while 1 is thought to allow access to multiple CPU cores. Since this is a undocumented setting, it is hard to tell for sure. If you see 100% CPU utilization, try the opposite setting,  There is even some debate if this works with Windows at all.
GPU_MAX_ALLOC_PERCENT   [0 – 100] – Maximum amount of  memory that can be allocated globally. Needs to be equal to or higher than the next setting.
GPU_SINGLE_ALLOC_PERCENT   [0 – 100] – Maximum amount of memory that can be allocated to a single process. This is limited by the above setting, so be sure to increase both.

文章出處



 

臉書網友討論
您需要登錄後才可以回帖 登錄 | 註冊 |

本版積分規則



Archiver|手機版|小黑屋|免責聲明|TShopping

GMT+8, 2021-10-17 20:13 , Processed in 0.313352 second(s), 25 queries .

本論壇言論純屬發表者個人意見,與 TShopping綜合論壇 立場無關 如有意見侵犯了您的權益 請寫信聯絡我們。

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回復 返回頂部 返回列表